AUS - R&D SaaS Environments overnight upgrade status
Incident Report for TechnologyOne Internal
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 09:58 AEST
Investigating
****** AUS ******
R&D SaaS Environment Status

DEV
----------
Some DataSets are NOT on the latest Instance

DataSets successfully upgraded to latest instance DEV-2024B-A043B
SAAS-DEV-QA, SAAS-PLATFORM-DEV-US, SAAS-ECM-DEV-SQL, SAAS-LICENCE

DataSets on instance DEV-2024B-A042B from 1 day ago (10/03/2024 11:35:12 PM)
SAAS-ZEBRA: Upgrade or Assignment is still in progress
SAAS-MIGCENT-CONF: Upgrade or Assignment is still in progress
SAAS-CPM-RA-DEV: Upgrade or Assignment is still in progress
SAAS-SDXP-DEV: Upgrade or Assignment is still in progress
SAAS-SDXP-DEV-PRESALES: Upgrade or Assignment is still in progress
SAAS-ECM-REFRESH: Upgrade or Assignment is still in progress

DataSets on instance DEV-2024B-A039A from 4 days ago (07/03/2024 11:36:30 PM)
SAAS-DEV-SQL: DataSet Rolled back due to Smoke Test Failure
SAAS-PLATFORM-DEV: Upgrade Successful

Deploy logs
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Dev/5153588?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_DevSecondaryDatasets1/5153971?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_DevSecondaryDatasets2/5153970?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_DevSecondaryDatasets3/5153972?buildTab=artifacts

REL 2024B
----------
DataSets are not on latest Instance
Latest Snapshot Code is - REL-2024B-A043

DataSets on instance REL-2024B-A042A from 1 day ago (11/03/2024 12:02:20 AM)
SAAS-REL-2024B-LGDXP: Upgrade was successful but DataSet is in an Unknown state
SAAS-REL-DXP-LG-SANDPIT: DataSet not upgraded due to Deploy not running
SAAS-REL-DXP-LG-LOCALDEV: DataSet not upgraded due to Deploy not running
SAAS-IM-PUBLIC: DataSet not upgraded due to Deploy not running
SAAS-REL-2024B-T1UNI: DataSet not upgraded due to Deploy not running
T1COLL-PRODDEV: DataSet not upgraded due to Deploy not running
SAAS-AUTOFT-2024B-GOLDONECOUNCILUK: DataSet not upgraded due to Deploy not running
SAAS-AUTOFT-2024B-GOLDONECOUNCILAU: DataSet not upgraded due to Deploy not running
SAAS-AUTOFT-2024B-GOLDSTUDENTAU: DataSet not upgraded due to Deploy not running

DataSets on instance REL-2024B-A041A from 2 days ago (10/03/2024 12:04:57 AM)
SAAS-REL-2024B-DXP: Upgrade was successful but DataSet is in an Unknown state
SAAS-IT: DataSet not upgraded due to Deploy not running

DataSets on instance REL-2024B-A040A from 3 days ago (09/03/2024 12:05:09 AM)
SAAS-REL-2024B: Upgrade was successful but DataSet is in an Unknown state
SAAS-AUTOFT-2024B-DAILYONECOUNCILAU: DataSet not upgraded due to Deploy not running
SAAS-AUTOFT-2024B-DAILYONECOUNCILUK: DataSet not upgraded due to Deploy not running

DataSets not assigned to an instance: SAAS-AUTOFT-2024B-DAILYSTUDENTAU, SAAS-AUTOFT-2024B-DAILYSTUDENTUK

Deploy logs
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2024b/5153625?buildTab=artifacts

REL 2024A
----------
Some DataSets are NOT on the latest Instance

DataSets successfully upgraded to latest instance REL-2024A-A248B
SAAS-REL-2024A, SAAS-REL-2024A-DXP, SAAS-AUTOFT-2024A-DAILYSTUDENTAU, SAAS-AUTOFT-2024A-DAILYONECOUNCILAU, SAAS-REL-2024A-T1UNI, SAAS-REL-2024A-CLEAN-ONECOUNCIL, SAAS-AUTOFT-2024A-DAILYONECOUNCILAU, SAAS-HRP-MULTI-CURRENT, SAAS-HRP-DEMO, SAAS-AUTOFT-2024A-GOLDONECOUNCILUK, SAAS-AUTOFT-2024A-DAILYONECOUNCILUK, SAAS-AUTOFT-2024A-DAILYSTUDENTUK

DataSets on instance REL-2024A-A246E from 1 day ago (11/03/2024 01:54:30 AM)
SAAS-REL-2024A-CLEAN-ONESTUDENT: Upgrade or Assignment is still in progress
RDSHOWCASE-HANDOVER: Upgrade or Assignment is still in progress
T1SOL-ONESTUDENTCONFIGUK-2024AB-RD: Upgrade or Assignment is still in progress
T1SOL-ONESTUDENTWORKSHOPUK-2024AB-RD: Upgrade or Assignment is still in progress
T1SOL-ONESTUDENTSANDPITUK-2024AB-RD: Upgrade or Assignment is still in progress

DataSets on instance REL-2024A-A245A from 2 days ago (10/03/2024 12:04:23 AM)
SAAS-REL-2024A-LGDXP: Upgrade was successful but DataSet is in an Unknown state

Deploy logs
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2024a/5153653?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2024aModernised/5153652?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2024aSecondaryDatasets1/5153974?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2024aSecondaryDatasets2/5153977?buildTab=artifacts

REL 2023B
----------
Some DataSets are NOT on the latest Instance

DataSets successfully upgraded to latest instance REL-2023B-A509A
SAAS-REL-2023B, SAAS-REL-2023B-DXP, SAAS-SUPRELB-APAC, SAAS-AUTOFT-2023B-GOLDONECOUNCILUK, SAAS-REL-2023B-LGDXP, SAAS-REL-DXP-LG-GOLD, SAAS-HRP-MULTI-PREVIOUS

DataSets on instance REL-2023B-A507A from 1 day ago (11/03/2024 12:14:32 AM)
SAAS-REL-2023B-T1UNI: Upgrade or Assignment is still in progress
SAAS-PPLGSPROD: Upgrade or Assignment is still in progress
SAAS-REL-2023B-CLEAN-ONESTUDENT: DataSet not upgraded due to Deploy not running
SAAS-REL-2023B-CLEAN-ONECOUNCIL: DataSet not upgraded due to Deploy not running
SAAS-REL-SPTPROVE: DataSet not upgraded due to Deploy not running
SAAS-CIA-LIVE-RELEASE-CURRENT: DataSet not upgraded due to Deploy not running
SAAS-CIA-LIVE-INTERNAL-USE: DataSet not upgraded due to Deploy not running
SAAS-REL-2023B-COUNCIL-PENTEST: DataSet not upgraded due to Deploy not running
SAAS-REL-2023B-STUDENT-PENTEST: DataSet not upgraded due to Deploy not running
SAAS-AUTOFT-2023B-DAILYSTUDENTUK: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILCONFIGAU-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILTESTAU-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILSANDPITAU-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILCONFIGNZ-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILTESTNZ-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONECOUNCILSANDPITNZ-2023AB-RD: DataSet not upgraded due to Deploy not running
T1SOL-ONEEDUCATIONCONFIGAU-2023AB: DataSet not upgraded due to Deploy not running
T1SOL-ONEEDUCATIONWORKSHOPAU-2023AB: DataSet not upgraded due to Deploy not running
T1SOL-ONEEDUCATIONSANDPITAU-2023AB: DataSet not upgraded due to Deploy not running

DataSets not assigned to an instance: SAAS-AUTOFT-2023B-DAILYSTUDENTAU, SAAS-AUTOFT-2023B-DAILYONECOUNCILAU, SAAS-AUTOFT-2023B-DAILYONECOUNCILUK

Deploy logs
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023b/5153668?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023bSecondaryDatasets1/5153910?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023bSecondaryDatasets2/5153909?buildTab=artifacts

REL 2023A
----------
Some DataSets are NOT on the latest Instance

DataSets successfully upgraded to latest instance REL-2023A-A744A
SAAS-REL-2023A, SAAS-REL-2023A-DXP, SAAS-REL-2023A-CLEAN-ONECOUNCIL, SAAS-REL-2023A-CLEAN-ONESTUDENT

DataSets on instance REL-2023A-A742A from 1 day ago (11/03/2024 01:09:47 AM)
SAAS-REL-2023A-T1UNI: Upgrade or Assignment is still in progress
SAAS-PLATFORM01: Upgrade or Assignment is still in progress
SAAS-HRP-MULTI-PREVIOUSX2: Upgrade or Assignment is still in progress
SAAS-SUPRELA-APAC: Upgrade or Assignment is still in progress
SAAS-AUTOFT-2023A-DAILYSTUDENTAU: Unable to retrieve DataSet status from Team City. Schema upgrade was successful but state is unknown
SAAS-REL-2023A-LGDXP: Unable to retrieve DataSet status from Team City. Schema upgrade was successful but state is unknown
SAAS-CIA-LIVE-RELEASE-PRIOR: Upgrade or Assignment is still in progress
SAAS-REL-2023A-COUNCIL-PENTEST: Upgrade or Assignment is still in progress
SAAS-REL-2023A-STUDENT-PENTEST: Upgrade or Assignment is still in progress

DataSets not assigned to an instance: SAAS-AUTOFT-2023A-DAILYONECOUNCILAU

Deploy logs
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023a/5153703?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023aSecondaryDatasets1/5154100?buildTab=artifacts
https://builds.code.one/buildConfiguration/T1SaaS_Deployments_Nightly_Rel2023aSecondaryDatasets2/5154099?buildTab=artifacts

This is an automated message. Please contact rd.environments.team@technologyonecorp.com with any issues
Posted Mar 12, 2024 - 07:00 AEST